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IMPORTANT INFORMATION !

This publication is an illustrated version of  PRMS help . Since the user can access
and print help directly from the application, help is considered the primary source for
information about PRMS.

When you print help directly from the application, the format is different from this
illustrated version; however, the text is the same. Therefore, NFC provides the
illustrated version only upon customer request.

For information about this publication, please contact the Directives and Analysis
Branch (DAB). Instructions for contacting DAB and other support sources are
provided in the About This Procedure  section of this publication.

Published and printed by the Directives and Analysis Branch
National Finance Center, U.S. Department of Agriculture

New Orleans, Louisiana
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About This Procedure

This procedure provides instructions for accessing and operating the Permissions System
(PRMS). The following information will help you use the procedure more effectively and locate
further assistance if needed.

How The Procedure Is Organized

The major sections of this procedure are described below:

Introduction  presents an overview of PRMS, including security access information and
instructions for accessing the system. It also provides basic operational information
including how to get help using PRMS.

Getting Started  provides instructions for logging onto PRMS for both mainframe and PC
applications and for using PRMS tool buttons, command buttons, functional/directional
keys, and pop-ups.

Using PRMS  provides step-by-step instructions for the processes performed in PRMS.

Field Instructions For PRMS Windows  contains instructions for or descriptions of the
fields on PRMS windows.

Reference Tables  provides tables for the profiles assigned to STAR and PRMS user.

Heading Index  provides an alphabetical list of all headings in the procedure. When a
heading is referenced, you can use this index to locate the page number.

To keep you informed about new or changed information related to this system, NFC issues short
publications called bulletins or amendments. This procedure and all related bulletins and
amendments are listed in the NFC External Publications Index, issued semiannually. Also, the
Bulletin Board on NFC’s home page (www.nfc.usda.gov) provides a list of all bulletins by title
and publication date. Users can choose to view and/or print bulletins from this Bulletin Board list.

If you receive this procedure after it has been amended, you will receive the publications with all
amendments and bulletins. Remove and insert amended pages according to the accompanying
page control chart so that your procedure is current.
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What Conventions Are Used

This procedure uses the following visual aids to identify certain kinds of information:

Convention Example

Important extra information is
identified by a note, warning, caution,
or reminder icon in the left margin.

Note:  This option is grayed out to users.

Figure references link figures with the
text. These references are printed in
bold sans serif font.

The Logon pop-up (Figure 1 ) is displayed.

References to headings in the
procedure are printed in the same font
as figure references.

Note:  When a heading is referenced
in the procedure, you can use the
Heading Index to locate the page
number.

Complete the Open field as indicated under
Run Pop-up Field Instructions .

References to menu options are
printed in bold italics .

From the Start menu, select Start > Run .

References to command buttons or
keyboard keys are printed in bold and
enclosed in brackets

To return to the previous window, click
[Close] .

enclosed in brackets.
You must press [Tab]  after completing the
User Id field in order to activate the [Add]
button.

Field names are printed in the margin.
Field specifications are printed in
italics.

Note:  Field entries are identified as
required1, conditional2, optional3, or no
entry4.

Agency No entry
This field is system generated. The agency
code is displayed in this field.

1Required You must enter data in the field. (Note: All mandatory fields on PRMS screens are highlighted to distinguish1Required You must enter data in the field. (Note: All mandatory fields on PRMS screens are highlighted to distinguish
required entries from optional entries. The highlighted fields must be completed to avoid rejection.)q g g j )

2Conditional You may be required to enter data, based on criteria indicated in the field instructions.y q ,
3Optional You may elect to enter data in the field. If the field is left blank, no data is system generated.p y , y g
4No entry You do not enter data in the field. The field instruction states the reason for no entry.

Who To Contact For Help

For questions about the system (including help with unusual conditions), contact the Customer
Support Center at 504-255-5230.

For questions about NFC processing, contact the Payroll/Personnel Operations Section at
504-255-4630.

For access to PRMS, contact your agency’s ADP security officer.

For questions about this procedure, contact the Directives and Analysis Branch at 504-255-5322.
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Introduction

This section presents the following topics:

About PRMS

Related Systems

Responsibilities

About PRMS

The Permissions System (PRMS) is a Windows-based application of the National Finance
Center (NFC). PRMS operates in a Windows format requiring Windows 95, Windows 98, or

Windows NT 4.0 or higher. PRMS is used to establish user profiles (roles) for * *  personal
computer (PC) applications (System For Time And Attendance Reporting (STAR)) after
users are established in the Employee System (EMCP).

Features of PRMS:

• Establishes user profiles (roles) for * *  STAR.

• PRMS for STAR contains the EMCP software. When a user requests PRMS for
STAR, EMCP is included.

Before an application that uses PRMS * * can be accessed, (1) system users must first be
entered in EMCP and (2) system users established in EMCP must be granted roles in PRMS.

* *PC applications require installation of PRMS. * *  There is no data included in the STAR
database upon installation. All STAR users must be entered in EMCP by the STAR System
Administrator.

Note:  Once the applicable version is installed, and users are set up in EMCP, roles can
be established in PRMS. Once these roles are established, users can access the
applicable application. Instructions for installing PRMS (and other NFC applications)
are available on the NFC Resource Center on the NFC home page at
www.nfc.usda.gov. If when trying to install PRMS, you get an ODBC error message,
you must first make sure that you are running Version 3.0 or greater of ODBC. If you
do not have Version 3.0 or greater, you must reinstall your mdac file. Windows 95 and
98 users should also reinstall the applicable dcom file. Also, when a System
Administrator reinstalls PRMS, the existing copy of PRMS along with the database
file are overlaid. Therefore, if you want to retain your database file, you must copy the
file to another drive before reinstalling PRMS.

* *

For more information, see:

PRMS Users

Hardware And Software Requirements
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PRMS Users

Agencies must designate an Administrator to establish roles in PRMS after the users are set

up in EMCP. This Administrator must grant these roles before users can begin working. * *
After the roles are assigned, a user can work in the application. Users can have more than one
role in a particular application.

Hardware And Software Requirements

You will need the following to run PRMS:

• A PC capable of supporting Windows 95, Windows 98, or Windows NT 4.0 or higher.

• Windows 95, Windows 98, or Windows NT 4.0 or higher.

• Super Video Graphics Array (SVGA) monitor set to 800x600 resolution and small
fonts.

• Inkjet printer or laser printer (with at least 1 megabyte of memory).

• PRMS application software.

Related Systems

Systems that interface with EMCP are described below:

Employee System (EMCP). EMCP is a Windows 95/NT/98 system designed, developed,
and maintained by NFC. EMCP is used to establish users for mainframe and PC
applications. Once users are established in EMCP, they are granted roles in PRMS.

FOCUS Reporting System (FOCUS). FOCUS is an online reporting system used to create
and generate ad hoc reports using database elements. PRMS users can request reports
through FOCUS.

* *

System For Time And Attendance Reporting (STAR). STAR is a Windows 95/NT/98
application designed, developed, and maintained by NFC. STAR is a T&A reporting
application used to record T&A data for the preparation of a transmit file sent to NFC for
processing. STAR users are granted roles in PRMS.

Responsibilities

Listed below are the responsibilities of the primary organizations involved in entering and
maintaining employee and/or user data:

The Agency:

• Downloads, installs, and maintains PRMS software for the appropriate application
users. (This individual should have a working knowledge of Windows 95,
Windows 98, or Windows NT 4.0 or higher.)
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• Assigns roles to users after being set up in EMCP.

NFC:

• Processes requests within established timeframes.

• Provides reports.
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Getting Started

This section provides the following topics:

Learning About PRMS

* *
Starting PRMS For STAR

Exiting PRMS

PRMS Operating Features

Permissions Menu

Learning About PRMS

To use PRMS, you must have knowledge of Microsoft Windows. Use your Windows user
guide for instructions on navigating in a Windows environment. Use this procedure for help
using PRMS.

For more information, see:

PRMS Help

Arranging And Viewing Multiple Windows

PRMS Help

The help feature is available to guide you as you use PRMS. To get help, select Help  from
the menu bar at any window. A drop-down menu is displayed with the following options:

• Help For This Window. Provides instructions for the current window.

• Help Contents. Provides extensive field level help for PRMS.

• Help For Help. Provides instructions for using help.

Arranging And Viewing Multiple Windows

The Window  option appears on all PRMS menu bars, allowing the arrangement of open
windows for simultaneous display. To use this feature, select Window  from any menu bar.
The Window pull-down menu (Figure 1 ) is displayed with the following option:

Figure 1. Window pull-down menu

The Cascade  option overlaps the windows so that each title bar is visible.
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* *

Starting PRMS For STAR

The PRMS for STAR software is available by Internet download, FTP download, on
CD-ROM, and on diskettes. To access the PRMS application from the Internet, go to the
NFC home page at www.nfc.usda.gov and link to the NFC Download Center.

To start PRMS for a STAR user:

1. From the Start menu, select Start > Programs > National Finance Center > Star
Permissions . The Permissions Menu window (Figure 2 ) is displayed.

Figure 2. Permissions Menu

Exiting PRMS

This section provides instructions for exiting PRMS.

To exit PRMS, select File > Exit  on the Permissions Menu. To exit the current window, click

.

PRMS Operating Features

PRMS is designed in a Windows format, providing mouse-driven, point-and-click
functionality; command buttons; and other Windows features. This section reviews these
basic Windows features and describes other features that are specific to PRMS.

Note:  Window  and Help  appear on all menu bars and display the same pull-down menus.
Instructions for using Window  are provided under Arranging And Viewing Multiple Windows .
Instructions for using Help  are provided under PRMS Help .
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For more information, see:

PRMS Tool Bar

PRMS Command Buttons

PRMS Pop-ups

PRMS Functional/Directional Keys

PRMS Message Pop-ups

PRMS Tool Bar

The PRMS tool bar is a row of tool (icon) buttons located below the menu bar. Each tool
button displays an icon that depicts its processing function. Tool buttons, like menu options,
are used to display windows and initiate functions that are relevant to the open window. Tool
buttons can be used as shortcuts for selecting options from the pull-down menus. In most
cases, the tool buttons can be used in lieu of the menu bar.

Tool buttons used throughout PRMS are shown in the following table:

PRMS Tool Buttons

Button Description

Used to add a record.

Used to close a window.

Used to delete a record.

Used to display help text.

Used to print the screen.

Used to search based on data entered.

Used to display the selected employee.

Used to update a record.

User Profile
Used to display the employee’s user profile.

PRMS Command Buttons

PRMS pop-ups contain command buttons that carry out an action described in the button’s
name. PRMS includes the following command buttons.
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PRMS Command Buttons

Button Description

Add
Used to add a record.

Cancel
Used to cancel a function.

Clear
Used to clear the detail area to add a record.

Close
Used to close the window.

Delete
Used to delete a record.

Find
Used to search for the data entered.

Print
Used to print.

Remove
Used to remove a user from the selected list.

Update
Used to update a record.

PRMS Pop-ups

Pop-ups do not have a menu bar or a tool bar; however, they do have command buttons that
carry out an action implied in the button’s name. For a list of command buttons that appear
on PRMS pop-ups, see PRMS Command Buttons .

PRMS Functional/Directional Keys

Your keyboard includes the following function keys to be used in PRMS.

Function Keys

Key Description

PF1
Used to display Help.

PF2
Used to search for the data entered.

PF3
Used to close the active window.

PF4
Used to add a record.
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Function Keys

DescriptionKey

PF5
Used to update a record.

PF6
Used to delete a record.

PF9
Used in conjunction with the Control key to select an
employee record.

Alt
Used in conjunction with the Hot Keys (underlined
characters) to perform certain actions.

Ctrl
Used in conjunction with various hot keys to perform
certain functions.

Delete
Used to delete text within a field.

Enter
Used to process an action.

Space
Bar

Used to advance within a field.

Tab
Used to advance to the next field.

PRMS Message Pop-ups

Throughout PRMS, message pop-ups appear when certain actions are performed. These
pop-ups notify the user of an action that must be taken and/or an error condition that must be
corrected. Command buttons are used on these pop-ups. These command buttons accept or
cancel the message. You must click a command button in order for the pop-up to disappear
and return to the active window. Following is an example of a message pop-up (Figure 3 ).
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Figure 3. Message pop-up

Permissions Menu

After accessing PRMS, the Permissions Menu (Figure 2 ) is displayed showing the
Permissions Menu bar with four options.

Below is a brief description of each option:

• File . Used to display the Select System, User List, and to close PRMS.

Note:  The Selected System option is for NFC use only and is grayed out to users.

• NFC Use. Used by NFC.

Note:  The NFC Use option is for NFC use only and is grayed out to users.

• Window . Used to cascade open windows.

• Help . Used to display help.

To display help for an option, move to the option and select Menu Option > Help  at any
window. The field level help (Figure 4 ) is displayed. To return to the previous PRMS

window, click .
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Figure 4. PRMS Help

Each option on the Permissions Menu (Figure 2 ) has a coordinating drop-down menu with
additional options. To select an option from the Permissions Menu, position the arrow at the
applicable selection and click the selection.

Instructions follow for selecting and using the applicable options.
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Using PRMS

This section presents the following topics:

* *
Searching For A User On The User List

Adding/Updating A User On The User List

Using The Employee List Search Pop-up

Using The Employee List Window

Assigning User Profiles

* *

Searching For A User On The User List

The first pop-up that appears when you select File > User List  from the Permissions
Menu (Figure 2 ) is the User List Search pop-up (Figure 5 ). This pop-up is used to search for
a record that was established in EMCP. Users on the User List are users that have already
been assigned roles.

Figure 5. User List Search pop-up

To search for a user:

1. From the Permissions Menu (Figure 2 ), select File > User List . The User List Search
pop-up (Figure 5 ) appears.

2. To search for a user on the User List, complete the fields as indicated under User List
Search Pop-up Field Instructions .

OR

To assign a new user, click [Cancel]  and follow the instructions under
Adding/Updating A User On The User List .
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3. Click [Find]  to search for the user or [Cancel]  to cancel the function and return to the
Permissions Menu (Figure 2 ). If you click [Find] , the User List window (Figure 6 ) is
displayed. For more information on the User List window, see Adding/Updating A
User On The User List .

Adding/Updating A User On The User List

The Administrator can add users established in EMCP to the User List. User Id’s are
assigned using this option. The User List window (Figure 6 ) is displayed by clicking [Find]
on the User List Search pop-up (Figure 5 ). For more information on using the User List
Search pop-up (Figure 5 ), see Searching For A User On The User List .

Figure 6. User List window

To add/update a user on the User List:

1. On the User List Search pop-up (Figure 5 ), click [Find]  after completing the fields as
indicated under User List Search Pop-up Field Instructions . The User List
window (Figure 6 ) is displayed.

2. Click . The Employee List Search pop-up (Figure 7 ) appears.

3. For information on the Employee List Search pop-up (Figure 7 ), see Using The
Employee List Search Pop-up .

4. Complete the fields as indicated under User List Window Field Instructions .

Note:  After completing the User Id field, you must press [Tab]  or [Enter]  to activate
the [Add]  button.

5. Click [Add]  to assign the user Id or click [Update]  to update the record.
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Note:  The Profiles column on the User List window (Figure 6 ) is used to designate
assigned user profiles. Y (yes) designates that user profiles have been assigned, and N
(no) designates that user profiles have not yet been assigned. The Profiles column on
the User List window (Figure 6 ) is not updated until you close the User List
window (Figure 6 ), return to the Permissions Menu (Figure 2 ), and reopen the User
List window (Figure 6 ).

Using The Employee List Search Pop-up

The Employee List Search pop-up (Figure 7 ) is used to search for an employee on the

Employee List. This pop-up appears when you click  on the User List window (Figure 6 ).
Users on the Employee List are employees that were set up in EMCP. These employees may
or may not have yet been assigned roles in PRMS.

Figure 7. Employee List Search pop-up

To search for a user on the Employee List:

1. On the User List window (Figure 6 ), click . The Employee List Search
pop-up (Figure 7 ) appears.

2. Complete the fields as indicated under Employee List Search Pop-up Field
Instructions .

3. Click [Find]  to search for the employee or [Cancel]  to cancel the function.

Using The Employee List Window

The Employee List window (Figure 8 ) displays a list of employees as a result of using the
Employee List Search pop-up (Figure 7 ). The Employee List window (Figure 8 ) is displayed
by clicking [Find]  or [Cancel]  on the Employee List Search pop-up (Figure 7 ). The Employee
List window (Figure 8 ) is used to select employees for which to assign profiles. For more
information on the Employee List window (Figure 8 ), see Employee List Window Field
Instructions .
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Figure 8. Employee List window

To use the Employee List window:

1. On the Employee List Search pop-up (Figure 7 ) click [Find]  or [Cancel] . The
Employee List window (Figure 8 ) is displayed.

2. Highlight the applicable employee and click . The User List window (Figure 6 ) for
the appropriate employee is displayed.

Assigning User Profiles

Once a user has been established in EMCP and assigned a user Id in PRMS, the user can be

assigned roles. The User Profiles window (Figure 9 ) * * is displayed by highlighting the

applicable employee and clicking User Profile  on the User List window (Figure 6 ). For
more information on the User Profiles window, see User Profiles Window Field Instructions .
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Figure 9. STAR User Profiles window

* *

To assign user profiles:

1. On the User List window (Figure 6 ), highlight the applicable employee and click
User Profile . The User Profiles window (Figure 9 ) * * is displayed.

2. Highlight the role(s) in the * * Name list box to be assigned to a user.

3. Click [Add]  to move the role(s) from the Available List to the Selected List.

OR

4. Click [Remove]  to move the role(s) from the Selected List to the Available List.
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Field Instructions For PRMS Windows

This section presents the following topics:

* *
Permissions Menu Field Instructions

* *
User List Search Pop-up Field Instructions

User List Window Field Instructions

Employee List Search Pop-up Field Instructions

Employee List Window Field Instructions

User Profiles Window Field Instructions

* *

Permissions Menu Field Instructions

The Permissions Menu (Figure 2 ) is displayed when you select
Start > Programs > National Finance Center > Star Permissions . The
Permissions Menu (Figure 2 ) is used to make selections and navigate in PRMS.

* *

User List Search Pop-up Field Instructions

The User List Search pop-up (Figure 5 ) appears when you select File > User List
from the Permissions Menu (Figure 2 ). The User List Search pop-up (Figure 5 ) is
used to search for a user that was set up in EMCP. For instructions on this
process, see Searching For A User On The User List .

Last Name
Type the user’s last name.

Note:  If you type a % (percent sign) in the Last Name field, a list of all available
users is displayed.

OR

Optional, alphanumeric, 40 positions max.



Title I, Chapter 25
Permissions System (PRMS)

20 Updated 10/03

User Id
Type the user’s Id.

User List Window Field Instructions

The User List window (Figure 6 ) is displayed when you click [Cancel]  on the
User List Search pop-up (Figure 5 ). The User List window (Figure 6 ) is used to
assign user Id’s to users established in EMCP. For instructions on this process,
see Adding/Updating A User On The User List .

System
This field is system generated. The application for which the user Id is being
granted is displayed in this field.

List Box
This field is system generated. A list of user names, user Id’s, and profile status is
displayed in this field. Once user profiles are assigned to a user, the profile
column is updated with a Y (yes). The status of the profiles is updated when you
close the User List window (Figure 6 ) and return to the window.

Detail

Name
This field is system generated based on the selection made on the Employee List
window (Figure 8 ). The user’s name appears in this field.

User Id
Type the user Id being assigned.

Note:  You must press [Tab]  after completing the User Id field to activate the [Add]
button.

Alternate User Id
Type the alternate user Id. This field is used to assign an alternate user Id to a
STAR user (i.e., to be used when one Timekeeper substitutes for another
Timekeeper).

Dept
This field is system generated.

Agency
This field is system generated.

POI
This field is system generated.

Servicing
Agency

This field is system generated.

Optional, alphanumeric, 8 positions max.

No Entry

No entry

∇

No entry

Required, alphanumeric, 8 positions max.

Optional, alphanumeric, 8 positions max.

No entry

No entry

No entry

No entry
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Employee List Search Pop-up Field Instructions

The Employee List Search pop-up (Figure 7 ) appears when you click  on the
User List window (Figure 6 ). The Employee List Search pop-up (Figure 7 ) is
used to search for an employee on the Employee List. For instructions on using
the Employee List Search pop-up (Figure 7 ), see Using The Employee List
Search Pop-up .

Last Name
Type the employee’s last name.

Note:  If you type a % (percent sign) in the Last Name field, the complete
employee list is displayed.

First Name
Type the employee’s first name.

SSN
Type the employee’s 9-digit SSN.

Employee List Window Field Instructions

The Employee List window (Figure 8 ) is displayed when you click [Find]  or
[Cancel]  on the Employee List Search pop-up (Figure 7 ). Employees are selected
from the Employee List window (Figure 8 ), and are then assigned roles. For more
information on the Employee List window (Figure 8 ), see Using The Employee
List Window .

List Box
This field is system generated based on information entered on the Employee List
Search pop-up (Figure 7 ). If you typed a % (percent sign) in the Last Name field
on the Employee List Search pop-up, the complete employee list is displayed.

Select the applicable employee and click  to display the User List window to
assign profiles to any employee.

User Profiles Window Field Instructions

The User Profiles window (Figure 9 ) * * is displayed when you highlight an

employee and click User Profile  on the User List window (Figure 6 ). The User
Profiles window (Figure 9 ) is used to assign roles to application users. For
instructions on this process, see Assigning User Profiles .

Optional, alphanumeric, 17 positions max.

Optional, alphanumeric, 12 positions max.

Optional, numeric, 9 positions

No entry



Title I, Chapter 25
Permissions System (PRMS)

22 Updated 10/03

System
This field is system generated. The acronym for the application for which you are
assigning roles is displayed in this field.

Id
This field is system generated. The user Id assigned on the User List window is
displayed in this field.

Name
This field is system generated. The name of the user is displayed in this field.

Available Profiles
This field is system generated. The profiles available for an application are listed
in this field. For a list of available profiles and definitions of these profiles for

STAR users, see STAR Profiles Table .* *

Selected Profiles
This field is system generated. The profiles selected for a user are displayed in
this field.

No entry

No entry

No entry

No entry

No entry
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Reference Tables

This section presents the following reference table:

STAR Profiles Table

* *

STAR Profiles Table

Timekeeper Allows the user to perform all T&A functions; to print employee data; to
convert data from the Personal Computer Time And Attendance Remote
Entry System (PC-TARE) to STAR; and to back up, restore, and archive
table data from the accounting and pay period tables.

System
Administrator

Creates and controls the user Id record for each authorized user; backs up
and restores files; imports and exports table files; archives data; and
converts data from PC-TARE to STAR.

Transmitter Prepares a transmit file and establishes Job Control Language.

Application
Administrator

Maintains and updates tables and establishes contact points.

User
Administrator

Assigns specific contact points for user access.

* *
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Heading Index

This index provides an alphabetical list of all headings in the procedure. When a heading is referenced, you
can use this index to locate the page number.

A
About PRMS, 1

Adding/Updating A User On The User List, 14

Agency, 21

* *
Arranging And Viewing Multiple Windows, 5

Assigning User Profiles, 17

Available Profiles, 22

C
* *

D
Dept, 21

Detail, 21

E
Employee List Search Pop-up Field Instructions, 21

Employee List Window Field Instructions, 22

Exiting PRMS, 8

F
Field Instructions For PRMS Windows, 19

First Name, 22

G
Getting Started, 5

H
Hardware And Software Requirements, 2

I
Id, 22

Introduction, 1

L
Last Name

Employee List Search Pop-up Field Instructions, 21
User List Search Pop-up Field Instructions, 20

Learning About PRMS, 5

List Box, 22

* *
User List Window Field Instructions, 21

N
Name

User List Window Field Instructions, 21
User Profiles Window Field Instructions, 22

* *

O
* *

P
* *
Permissions Menu, 11

Permissions Menu Field Instructions, 20

POI, 21

PRMS Command Buttons, 9
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PRMS Functional/Directional Keys, 10

PRMS Help, 5

PRMS Message Pop-ups, 11

PRMS Operating Features, 8

PRMS Pop-ups, 10

* *
PRMS Tool Bar, 8

PRMS Users, 2

R
Reference Tables, 27

Related Systems, 2

Responsibilities, 3

S
Searching For A User On The User List, 13

Selected Profiles, 23

* *

* *
Servicing Agency, 21

SSN, 22

STAR Profiles Table, 27

* *
Starting PRMS For STAR, 8

System
User List Window Field Instructions, 21
User Profiles Window Field Instructions, 22

U
User Id, 19

* *
User List Search Pop-up Field Instructions, 20
User List Window Field Instructions, 21

User List Search Pop-up Field Instructions, 20

User List Window Field Instructions, 20

User Profiles Window Field Instructions, 22

Using PRMS, 13

Using The Employee List Search Pop-up, 15

Using The Employee List Window, 16




